summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libfmt/libfmt-5.1.0.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-5.1.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-libs/libfmt/libfmt-5.1.0.ebuild b/dev-libs/libfmt/libfmt-5.1.0.ebuild
deleted file mode 100644
index 205d52c52e72..000000000000
--- a/dev-libs/libfmt/libfmt-5.1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib versionator
-
-DESCRIPTION="Small, safe and fast formatting library"
-HOMEPAGE="https://github.com/fmtlib/fmt"
-
-LICENSE="BSD-2"
-IUSE="test"
-SLOT="0/$(get_major_version)"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/fmt-${PV}"
-fi
-
-DEPEND=""
-RDEPEND=""
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
- -DFMT_LIB_DIR="$(get_libdir)"
- -DFMT_TEST=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
-}