summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libg15render/libg15render-9999.ebuild')
-rw-r--r--dev-libs/libg15render/libg15render-9999.ebuild66
1 files changed, 30 insertions, 36 deletions
diff --git a/dev-libs/libg15render/libg15render-9999.ebuild b/dev-libs/libg15render/libg15render-9999.ebuild
index 58ded405385e..bafaecea0fdc 100644
--- a/dev-libs/libg15render/libg15render-9999.ebuild
+++ b/dev-libs/libg15render/libg15render-9999.ebuild
@@ -1,57 +1,51 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-ESVN_PROJECT=g15tools/trunk
-ESVN_REPO_URI="https://svn.code.sf.net/p/g15tools/code/trunk/${PN}"
+EAPI=8
-inherit subversion base eutils autotools
+inherit autotools
DESCRIPTION="Small library for display text and graphics on a Logitech G15 keyboard"
-HOMEPAGE="https://sourceforge.net/projects/g15tools/"
-[[ $PV = *9999* ]] || SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+HOMEPAGE="https://gitlab.com/menelkir/libg15render"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/menelkir/libg15render.git"
+else
+ SRC_URI="https://gitlab.com/menelkir/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-
IUSE="truetype"
RDEPEND="
- dev-libs/libg15
- truetype? ( media-libs/freetype )
-"
-DEPEND=${RDEPEND}
-
-src_unpack() {
- if [[ ${PV} = *9999* ]]; then
- subversion_src_unpack
- fi
-}
+ >=dev-libs/libg15-3.0
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ truetype? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.4-docdir.patch"
+)
src_prepare() {
- # Merged upstream
- #epatch "${FILESDIR}/${PN}-1.2-pixel-c.patch"
-
- if [[ ${PV} = *9999* ]]; then
- subversion_wc_info
- fi
- base_src_prepare
- if [[ ${PV} = *9999* ]]; then
- eautoreconf
- fi
+ default
+ eautoreconf
}
src_configure() {
- econf \
- --disable-static \
- $(use_enable truetype ttf )
+ local myeconfargs=(
+ --disable-static
+ $(use_enable truetype ttf)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
- emake DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} install || die "make install failed"
- rm "${ED}/usr/share/doc/${PF}/COPYING"
+ default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ # no static archives
+ find "${ED}" -type f -name '*.la' -delete || die
}