summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgweather/libgweather-3.26.2.ebuild')
-rw-r--r--dev-libs/libgweather/libgweather-3.26.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libgweather/libgweather-3.26.2.ebuild b/dev-libs/libgweather/libgweather-3.26.2.ebuild
new file mode 100644
index 000000000000..81bb7f8332d6
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.26.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}