summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/Manifest1
-rw-r--r--dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch18
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild32
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild33
-rw-r--r--dev-libs/libmcrypt/metadata.xml12
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-libs/libmcrypt/Manifest b/dev-libs/libmcrypt/Manifest
new file mode 100644
index 000000000000..ce9f657c03b7
--- /dev/null
+++ b/dev-libs/libmcrypt/Manifest
@@ -0,0 +1 @@
+DIST libmcrypt-2.5.8.tar.gz 1335178 SHA256 e4eb6c074bbab168ac47b947c195ff8cef9d51a211cdd18ca9c9ef34d27a373e SHA512 471a4e0dcbede836c975697a4edd5c3a53d555dde122a045d702e619d7e9768c7abc1ab541c79829f644b70241ac2e0cd274cf22499e47862983401566ca1fd1 WHIRLPOOL 2fbe22466ecd42161e0de75dfdcdd42edd7f5f1422a2fd9b8bc4bf81f7005749e500058bbb62827f8be34fb707c70fd5920f37b2e27743814d96dd89c03f7deb
diff --git a/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
new file mode 100644
index 000000000000..ca31df4b2719
--- /dev/null
+++ b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
@@ -0,0 +1,18 @@
+--- KNOWN-BUGS 2008-12-13 15:31:49.000000000 -0500
++++ /dev/null 2008-12-13 02:05:21.751517562 -0500
+@@ -1 +0,0 @@
+-- cast-256 and rc6 do not work properly on Alpha (64 bit) machines
+--- lib/mcrypt_modules.h.orig 2008-12-13 15:33:06.000000000 -0500
++++ lib/mcrypt_modules.h 2008-12-13 15:25:01.000000000 -0500
+@@ -1,7 +1,7 @@
+-#define rotl32(x,n) (((x) << ((word32)(n))) | ((x) >> (32 - (word32)(n))))
+-#define rotr32(x,n) (((x) >> ((word32)(n))) | ((x) << (32 - (word32)(n))))
+-#define rotl16(x,n) (((x) << ((word16)(n))) | ((x) >> (16 - (word16)(n))))
+-#define rotr16(x,n) (((x) >> ((word16)(n))) | ((x) << (16 - (word16)(n))))
++#define rotl32(x,n) (((x) << ((word32)(n & 31))) | ((x) >> (32 - (word32)(n & 31))))
++#define rotr32(x,n) (((x) >> ((word32)(n & 31))) | ((x) << (32 - (word32)(n & 31))))
++#define rotl16(x,n) (((x) << ((word16)(n & 15))) | ((x) >> (16 - (word16)(n & 15))))
++#define rotr16(x,n) (((x) >> ((word16)(n & 15))) | ((x) << (16 - (word16)(n & 15))))
+
+ /* Use hardware rotations.. when available */
+ #ifdef swap32
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
new file mode 100644
index 000000000000..9c05f5cce796
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rotate-mask.patch
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+ prepalldocs
+}
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild
new file mode 100644
index 000000000000..c683e2e486e4
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rotate-mask.patch
+ mv configure.in configure.ac
+ mv libltdl/configure.in libltdl/configure.ac
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac libltdl/configure.ac || die
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+}
diff --git a/dev-libs/libmcrypt/metadata.xml b/dev-libs/libmcrypt/metadata.xml
new file mode 100644
index 000000000000..0549001de3c4
--- /dev/null
+++ b/dev-libs/libmcrypt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mcrypt</remote-id>
+ </upstream>
+</pkgmetadata>