summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmspack/libmspack-9999.ebuild')
-rw-r--r--dev-libs/libmspack/libmspack-9999.ebuild58
1 files changed, 26 insertions, 32 deletions
diff --git a/dev-libs/libmspack/libmspack-9999.ebuild b/dev-libs/libmspack/libmspack-9999.ebuild
index 4c72d6fbe69a..2a4ad5dfcc64 100644
--- a/dev-libs/libmspack/libmspack-9999.ebuild
+++ b/dev-libs/libmspack/libmspack-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
inherit git-r3
MY_P="${PN}-9999"
else
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/libmspack/libmspack-${MY_PV}.tar.gz"
@@ -21,53 +21,47 @@ HOMEPAGE="https://www.cabextract.org.uk/libmspack/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="debug doc static-libs"
-
-DEPEND=""
-RDEPEND=""
+IUSE="debug doc"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == *9999 ]] ; then
# Re-create file layout from release tarball
- pushd "${WORKDIR}" &>/dev/null || die
+ pushd "${WORKDIR}" > /dev/null || die
+
cp -aL "${S}"/${PN} "${WORKDIR}"/${PN}-source || die
rm -r "${S}" || die
mv "${WORKDIR}"/${PN}-source "${S}" || die
- popd &>/dev/null || die
+
+ popd > /dev/null || die
fi
default
eautoreconf
-
- multilib_copy_sources
}
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable debug) \
- $(use_enable static-libs static)
+src_configure() {
+ econf $(use_enable debug)
}
-multilib_src_test() {
- if multilib_is_native_abi; then
- default
- cd "${S}"/test && "${BUILD_DIR}"/test/cabd_test || die
- fi
+src_test() {
+ default
+
+ cd "${S}"/test || die
+ ./cabd_test || die
}
-multilib_src_install_all() {
- DOCS=(AUTHORS ChangeLog NEWS README TODO)
- use doc && HTML_DOCS=(doc/*)
- default_src_install
- if use doc; then
- rm "${ED%/}"/usr/share/doc/"${PF}"/html/{Makefile*,Doxyfile*} || die
+src_install() {
+ use doc && HTML_DOCS=( doc/. )
+
+ default
+
+ if use doc ; then
+ rm "${ED}"/usr/share/doc/"${PF}"/html/{Makefile*,Doxyfile*} || die
fi
find "${ED}" -name '*.la' -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
+ find "${ED}" -name "*.a" -delete || die
}