summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnatspec/libnatspec-0.3.0.ebuild')
-rw-r--r--dev-libs/libnatspec/libnatspec-0.3.0.ebuild45
1 files changed, 20 insertions, 25 deletions
diff --git a/dev-libs/libnatspec/libnatspec-0.3.0.ebuild b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
index beeaea380a0b..d6fde3e9c93e 100644
--- a/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
+++ b/dev-libs/libnatspec/libnatspec-0.3.0.ebuild
@@ -1,48 +1,43 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools python-single-r1
+inherit autotools
DESCRIPTION="library to smooth charset/localization issues"
HOMEPAGE="http://natspec.sourceforge.net/"
-SRC_URI="mirror://sourceforge/natspec/${P}.tar.bz2"
+SRC_URI="https://downloads.sourceforge.net/natspec/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="doc python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="doc"
-RDEPEND="
- dev-libs/popt
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- python? ( dev-lang/tcl:0= )"
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-text/doxygen )"
PATCHES=(
"${FILESDIR}"/${PN}-0.2.6-iconv.patch
+ "${FILESDIR}"/${PN}-0.3.0-bashisms.patch
+ "${FILESDIR}"/${PN}-0.3.0-doxygen.patch
)
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_prepare() {
default
- # regenerate to fix imcompatible readlink usage
- rm -f "${S}"/ltmain.sh "${S}"/libtool || die
+ # regenerate to fix incompatible readlink usage
eautoreconf
}
src_configure() {
- use doc || export ac_cv_prog_DOX=no
# braindead configure script does not disable python on --without-python
- econf $(use python && use_with python)
+ econf $(use_with doc doxygen)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}