summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch')
-rw-r--r--dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch b/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch
new file mode 100644
index 000000000000..88a776dd85b8
--- /dev/null
+++ b/dev-libs/libnsfb/files/libnsfb-0.1.0-autodetect.patch
@@ -0,0 +1,21 @@
+--- libnsfb-0.1.0/Makefile
++++ libnsfb-0.1.0/Makefile
+@@ -23,10 +23,18 @@
+ NSFB_XCB_PKG_NAMES := xcb xcb-icccm xcb-image xcb-keysyms xcb-atom
+
+ # determine which surface handlers can be compiled based upon avalable library
++ifeq ($(WITH_VNC),yes)
+ $(eval $(call pkg_config_package_available,NSFB_VNC_AVAILABLE,libvncserver))
++endif
++ifeq ($(WITH_SDL),yes)
+ $(eval $(call pkg_config_package_available,NSFB_SDL_AVAILABLE,sdl))
++endif
++ifeq ($(WITH_XCB),yes)
+ $(eval $(call pkg_config_package_available,NSFB_XCB_AVAILABLE,$(NSFB_XCB_PKG_NAMES)))
++endif
++ifeq ($(WITH_WLD),yes)
+ $(eval $(call pkg_config_package_available,NSFB_WLD_AVAILABLE,wayland-client))
++endif
+
+ # surfaces not detectable via pkg-config
+ NSFB_ABLE_AVAILABLE := no