summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liboil/liboil-0.3.17-r2.ebuild')
-rw-r--r--dev-libs/liboil/liboil-0.3.17-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/liboil/liboil-0.3.17-r2.ebuild b/dev-libs/liboil/liboil-0.3.17-r2.ebuild
new file mode 100644
index 000000000000..a56cf8e92aa3
--- /dev/null
+++ b/dev-libs/liboil/liboil-0.3.17-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib autotools-multilib
+
+DESCRIPTION="Library of simple functions that are optimized for various CPUs"
+HOMEPAGE="http://liboil.freedesktop.org/"
+SRC_URI="http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0.3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+examples static-libs test"
+
+RDEPEND="examples? ( dev-libs/glib:2 )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig"
+DOCS=( AUTHORS BUG-REPORTING HACKING NEWS README )
+
+src_prepare() {
+ if ! use examples; then
+ sed "s/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ if ! use test; then
+ sed "s/^\(SUBDIRS =.*\)testsuite\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ epatch "${FILESDIR}/${P}-amd64-cpuid.patch"
+ has x32 $(get_all_abis) && epatch "${FILESDIR}"/${PN}-0.3.17-x32.patch
+}
+
+src_configure() {
+ strip-flags
+ filter-flags -O?
+ append-flags -O2
+
+ autotools-multilib_src_configure
+}
+
+pkg_postinst() {
+ if ! use examples; then
+ ewarn "You have disabled examples USE flag. Beware that upstream might"
+ ewarn "want the output of some utilities that are only built with"
+ ewarn "USE='examples' if you report bugs to them."
+ fi
+}