summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-9999.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
new file mode 100644
index 000000000000..b0a109807c08
--- /dev/null
+++ b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="https://github.com/bitcoin/secp256k1.git"
+inherit git-2 autotools eutils
+
+MyPN=secp256k1
+DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
+HOMEPAGE="https://github.com/bitcoin/${MyPN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="asm doc endomorphism gmp test"
+
+REQUIRED_USE="
+ asm? ( amd64 )
+"
+RDEPEND="
+ gmp? ( dev-libs/gmp:0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/openssl:0 )
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-benchmark \
+ $(use_enable test tests) \
+ $(use_enable endomorphism) \
+ --with-asm=$(usex asm auto no) \
+ --with-bignum=$(usex gmp gmp no) \
+ --disable-static
+}
+
+src_install() {
+ if use doc; then
+ dodoc README.md
+ fi
+
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}