summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxdg-basedir')
-rw-r--r--dev-libs/libxdg-basedir/Manifest2
-rw-r--r--dev-libs/libxdg-basedir/files/libxdg-basedir-1.2.0-buffer-overflow.patch26
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild50
-rw-r--r--dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild47
-rw-r--r--dev-libs/libxdg-basedir/metadata.xml17
5 files changed, 60 insertions, 82 deletions
diff --git a/dev-libs/libxdg-basedir/Manifest b/dev-libs/libxdg-basedir/Manifest
index 2fe7a3ceb60d..c2fba695e2f4 100644
--- a/dev-libs/libxdg-basedir/Manifest
+++ b/dev-libs/libxdg-basedir/Manifest
@@ -1 +1 @@
-DIST libxdg-basedir-1.2.0.tar.gz 30159 BLAKE2B cd9eacf6d32e0f27aa4a9092fb919f027fe77905cf8cad2f3d860d93f9784bbcf85336704fd9241d58769e48b2a8a7e4b4ed306ff32328f1ddc7cce7b014dc09 SHA512 8584405d45e0b57e570666b6eab6d99d70411d00f88965826c9ed0292372385668f190157a10ff536f3a5a59fd0031b332ecbb8a38ac64eda1b04a0603997406
+DIST libxdg-basedir-1.2.3.tar.gz 30971 BLAKE2B 63e8197f33db1200573b03cb58e4760ebc9a58f132902f8290822d9235be27e22bc4b763150a526cce23be60d2d535cd8627259180edce4d889a077d4b0de20c SHA512 e672da0d9cd3c27c9113f6053b79127e615e5d84bde81305242f506e930869d8492304aac26a0296528d5a32530e4a743acecb6a25f58372ac597af284429f7c
diff --git a/dev-libs/libxdg-basedir/files/libxdg-basedir-1.2.0-buffer-overflow.patch b/dev-libs/libxdg-basedir/files/libxdg-basedir-1.2.0-buffer-overflow.patch
deleted file mode 100644
index 4cd601cbde54..000000000000
--- a/dev-libs/libxdg-basedir/files/libxdg-basedir-1.2.0-buffer-overflow.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 14e000f696ef8b83264b0ca4407669bdb365fb23 Mon Sep 17 00:00:00 2001
-From: Timmy Weerwag <timmy@timmyweerwag.nl>
-Date: Sun, 16 Mar 2014 17:54:14 +0100
-Subject: [PATCH] Overflow bug
-
-Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
----
- src/basedir.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/basedir.c b/src/basedir.c
-index 68ab879..1a2a8c4 100644
---- a/src/basedir.c
-+++ b/src/basedir.c
-@@ -574,7 +574,7 @@ static char * xdgGetRelativeHome(const char *envname, const char *relativefallba
- unsigned int homelen;
- if (!(home = xdgGetEnv("HOME")))
- return NULL;
-- if (!(relhome = (char*)malloc((homelen = strlen(home))+fallbacklength))) return NULL;
-+ if (!(relhome = (char*)malloc((homelen = strlen(home))+fallbacklength+1))) return NULL;
- memcpy(relhome, home, homelen);
- memcpy(relhome+homelen, relativefallback, fallbacklength+1);
- }
---
-1.8.3.2
-
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
deleted file mode 100644
index 96a53b458718..000000000000
--- a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils
-
-DESCRIPTION="Small library to access XDG Base Directories Specification paths"
-HOMEPAGE="https://github.com/devnev/libxdg-basedir"
-SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-solaris"
-IUSE="doc static-libs"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-buffer-overflow.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static) \
- $(use_enable doc doxygen-html)
-}
-
-src_compile() {
- emake
-
- if use doc; then
- emake doxygen-doc
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-
- find "${D}" -type f -name '*.la' -delete
-}
diff --git a/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
new file mode 100644
index 000000000000..e4e7f70a1632
--- /dev/null
+++ b/dev-libs/libxdg-basedir/libxdg-basedir-1.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Small library to access XDG Base Directories Specification paths"
+HOMEPAGE="https://github.com/devnev/libxdg-basedir"
+SRC_URI="https://github.com/devnev/libxdg-basedir/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
+IUSE="doc"
+
+BDEPEND="doc? ( app-text/doxygen )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc doxygen-html)
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ emake doxygen-doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/dev-libs/libxdg-basedir/metadata.xml b/dev-libs/libxdg-basedir/metadata.xml
index 26b0caef5e23..1478f0b1fe68 100644
--- a/dev-libs/libxdg-basedir/metadata.xml
+++ b/dev-libs/libxdg-basedir/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">devnev/libxdg-basedir</remote-id>
- </upstream>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">devnev/libxdg-basedir</remote-id>
+ </upstream>
</pkgmetadata>