summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxslt/files/libxslt-1.1.28-manual-python.patch')
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.28-manual-python.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libxslt/files/libxslt-1.1.28-manual-python.patch b/dev-libs/libxslt/files/libxslt-1.1.28-manual-python.patch
new file mode 100644
index 000000000000..019f3253d876
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.28-manual-python.patch
@@ -0,0 +1,36 @@
+From 1671e1004e18fa9bbce410050d1365374ececb6a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 18 Dec 2012 02:22:47 -0500
+Subject: [PATCH] build/test/install python bindings manually
+
+To support building for multiple python ABIs, we want to skip checks for
+python in configure, and build/test/install python bindings manually.
+---
+ configure.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index fc8d5a8..6312c37 100644
+--- a/configure.in
++++ b/configure.in
+@@ -296,7 +296,7 @@ PYTHON_INCLUDES=
+ PYTHON_SITE_PACKAGES=
+ pythondir=
+ AC_ARG_WITH(python, [ --with-python[=DIR] Build Python bindings if found])
+-if test "$with_python" != "no" ; then
++if false ; then
+ if test -x "$with_python/bin/python"
+ then
+ echo Found python in $with_python/bin/python
+@@ -365,7 +365,7 @@ except: print 0"`
+ pythondir='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+ fi
+ fi
+-AM_CONDITIONAL(WITH_PYTHON, test "$PYTHON_INCLUDES" != "")
++AM_CONDITIONAL(WITH_PYTHON, test "$with_python" != "no")
+ if test "$PYTHON_INCLUDES" != ""
+ then
+ PYTHON_SUBDIR=python
+--
+1.8.0.2
+