summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/linux-syscall-support/linux-syscall-support-2022.10.12.ebuild')
-rw-r--r--dev-libs/linux-syscall-support/linux-syscall-support-2022.10.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/linux-syscall-support/linux-syscall-support-2022.10.12.ebuild b/dev-libs/linux-syscall-support/linux-syscall-support-2022.10.12.ebuild
new file mode 100644
index 000000000000..2363dd646405
--- /dev/null
+++ b/dev-libs/linux-syscall-support/linux-syscall-support-2022.10.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Linux Syscall Support"
+HOMEPAGE="https://chromium.googlesource.com/linux-syscall-support"
+#SRC_URI="https://chromium.googlesource.com/${PN}/+archive/refs/tags/v${PV}.tar.gz
+SRC_URI="https://dev.gentoo.org/~tupone/distfiles/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ sed -i -e "/fallocate/d" tests/Makefile || die
+ mkdir lss || die
+ cp linux_syscall_support.h lss/ || die
+}
+
+src_test() {
+ emake -C tests
+}
+
+src_install() {
+ doheader -r lss
+}