summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/papi/papi-5.5.1.ebuild')
-rw-r--r--dev-libs/papi/papi-5.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/papi/papi-5.5.1.ebuild b/dev-libs/papi/papi-5.5.1.ebuild
new file mode 100644
index 000000000000..610d20523922
--- /dev/null
+++ b/dev-libs/papi/papi-5.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils fortran-2 versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ local myeconfargs=(
+ --with-shlib
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ../RE*
+}