summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/softhsm/softhsm-1.3.7.ebuild')
-rw-r--r--dev-libs/softhsm/softhsm-1.3.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/softhsm/softhsm-1.3.7.ebuild b/dev-libs/softhsm/softhsm-1.3.7.ebuild
new file mode 100644
index 000000000000..9b6e5df77abc
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-1.3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="http://www.opendnssec.org/"
+SRC_URI="http://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/botan[threads]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --localstatedir=/var \
+ --with-botan="${EPREFIX}/usr/" \
+ $(use_enable amd64 64bit) \
+ $(use debug && echo "--with-loglevel=4")
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}