summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/starpu/starpu-1.1.5-r1.ebuild')
-rw-r--r--dev-libs/starpu/starpu-1.1.5-r1.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-libs/starpu/starpu-1.1.5-r1.ebuild b/dev-libs/starpu/starpu-1.1.5-r1.ebuild
index f6b978c34f00..c6fda9dd478c 100644
--- a/dev-libs/starpu/starpu-1.1.5-r1.ebuild
+++ b/dev-libs/starpu/starpu-1.1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SLOT="0/8"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl
- qt4 static-libs test"
+ static-libs test"
RDEPEND="
sys-apps/hwloc:0=
@@ -28,11 +28,7 @@ RDEPEND="
fftw? ( sci-libs/fftw:3.0= )
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
- opengl? ( media-libs/freeglut:0= )
- qt4? ( >=dev-qt/qtgui-4.7:4
- >=dev-qt/qtopengl-4.7:4
- >=dev-qt/qtsql-4.7:4
- x11-libs/qwt:5 )"
+ opengl? ( media-libs/freeglut:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -53,6 +49,7 @@ src_configure() {
econf \
--disable-build-examples \
+ --disable-starpu-top \
$(use_enable cuda) \
$(use_enable debug) \
$(use_enable doc build-doc) \
@@ -60,7 +57,6 @@ src_configure() {
$(use_enable gcc-plugin gcc-extensions) \
$(use_enable opencl) \
$(use_enable opengl opengl-render) \
- $(use_enable qt4 starpu-top) \
$(use_enable static-libs static) \
$(use_with mpi mpicc "$(type -P mpicc)") \
$(use cuda && use_enable blas magma) \