summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/univalue/univalue-1.0.5.ebuild')
-rw-r--r--dev-libs/univalue/univalue-1.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/univalue/univalue-1.0.5.ebuild b/dev-libs/univalue/univalue-1.0.5.ebuild
new file mode 100644
index 000000000000..e760de84d571
--- /dev/null
+++ b/dev-libs/univalue/univalue-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ universal value object and JSON library"
+HOMEPAGE="https://github.com/jgarzik/univalue"
+SRC_URI="https://codeload.github.com/jgarzik/${PN}/tar.gz/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~mips ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}