summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uriparser/uriparser-0.8.4.ebuild')
-rw-r--r--dev-libs/uriparser/uriparser-0.8.4.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/uriparser/uriparser-0.8.4.ebuild b/dev-libs/uriparser/uriparser-0.8.4.ebuild
index 97ad9a716173..11c9e1d59348 100644
--- a/dev-libs/uriparser/uriparser-0.8.4.ebuild
+++ b/dev-libs/uriparser/uriparser-0.8.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+inherit epatch autotools
+
DESCRIPTION="Uriparser is a strictly RFC 3986 compliant URI parsing library in C"
HOMEPAGE="http://uriparser.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -20,6 +22,14 @@ DEPEND="virtual/pkgconfig
REQUIRED_USE="test? ( unicode )"
+PATCHES=( "${FILESDIR}"/${P}-doc-install.patch )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ epatch_user
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-sizedown \