summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/userspace-rcu/userspace-rcu-0.10.1.ebuild')
-rw-r--r--dev-libs/userspace-rcu/userspace-rcu-0.10.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/userspace-rcu/userspace-rcu-0.10.1.ebuild b/dev-libs/userspace-rcu/userspace-rcu-0.10.1.ebuild
new file mode 100644
index 000000000000..0576c317633d
--- /dev/null
+++ b/dev-libs/userspace-rcu/userspace-rcu-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="userspace RCU (read-copy-update) library"
+HOMEPAGE="http://lttng.org/urcu"
+SRC_URI="http://lttng.org/files/urcu/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs regression-test test"
+
+DEPEND="test? ( sys-process/time )"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ default
+ if use regression-test; then
+ emake -C tests/regression regtest
+ fi
+}