summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild')
-rw-r--r--dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild b/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild
new file mode 100644
index 000000000000..6530a32be9e4
--- /dev/null
+++ b/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="C client interface to Zookeeper server"
+HOMEPAGE="https://zookeeper.apache.org/"
+SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}/zookeeper-${PV}/src/c"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with test cppunit)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ default
+ use doc && dohtml docs/html/*
+}