summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mathjax/Manifest1
-rw-r--r--dev-libs/mathjax/mathjax-2.7.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
index 496072083fa7..60e9420aa42d 100644
--- a/dev-libs/mathjax/Manifest
+++ b/dev-libs/mathjax/Manifest
@@ -1 +1,2 @@
DIST mathjax-2.7.0.tar.gz 24594403 BLAKE2B 7cadfe7565a7ebba3569fb298a097f07081926b843a06c3c32447757eb0a5d463d654f20c42821010c81c59819bb14fdc5e84a39e87106bb6808bd6c9ca52bb7 SHA512 2a7c2b4a4991485c18f78dda4115da05a31c1a2d952c403726e99d22fd26f166298199238ad482e53b63b5414be687f325b586f5ebe4e2d552447c929415b350
+DIST mathjax-2.7.4.tar.gz 25355532 BLAKE2B 0bed5224356757c64989de8b9355f5c2505f1fa951456c52caf1cc0a9b5a864633ce5299cc9b67b1e5c743e39bcb6aee787a76d6871fc998b614d62e12499f6f SHA512 cddc4c64c188620307f0ede3b0bc7ba071f78702ba6315426d8c83129543a6b81a3a9a115f88017e23b5094b7aefd934c39aeec9688419830e33f9fd0fb1de7e
diff --git a/dev-libs/mathjax/mathjax-2.7.4.ebuild b/dev-libs/mathjax/mathjax-2.7.4.ebuild
new file mode 100644
index 000000000000..5aaff1048750
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.7.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_install() {
+ local DOCS=( README* )
+ use doc && local HTML_DOCS=( docs/html/* )
+ default
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r test/*
+ fi
+ rm -r test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}