summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nettle/Manifest1
-rw-r--r--dev-libs/nettle/files/nettle-3.3-ecc-add-eh.patch32
-rw-r--r--dev-libs/nettle/nettle-3.3-r2.ebuild66
3 files changed, 0 insertions, 99 deletions
diff --git a/dev-libs/nettle/Manifest b/dev-libs/nettle/Manifest
index 2dbf9cd3960b..a6f524c73a25 100644
--- a/dev-libs/nettle/Manifest
+++ b/dev-libs/nettle/Manifest
@@ -1,2 +1 @@
-DIST nettle-3.3.tar.gz 1887927 BLAKE2B 4bcf3c4bfb9f9dae97ea6780d146f3313e8b51182d9942e69581428d9f602d16467d37f993700a4e94e2e0dee17bdf354694c94d0383164c3de6e57e7e24de4e SHA512 271981d89766f151af3cdc4e5fc43c438222f0f6f44475bad114f4209955b5235fced6526c7abca001cca223e8cfcd2a6bf389b160b305a499e7acf52425ec70
DIST nettle-3.4.tar.gz 1935069 BLAKE2B b73c88236c8233360607a6ed65cd4f6d19bfbbf683b46149326ce3440bf0a42b8add69de5c64145720163b1095fdab3cb8bf410c2ef727d0ea4fb58391ff0f14 SHA512 3bea3aabd2c99cc42d084a94fd6b0b5dbdb24cd6c7020271a6ee87a81a904b21b21756f590cb1afdf2e85fd1cb59e5c3651c5c4032e30204e7ea6f8801d1ea3b
diff --git a/dev-libs/nettle/files/nettle-3.3-ecc-add-eh.patch b/dev-libs/nettle/files/nettle-3.3-ecc-add-eh.patch
deleted file mode 100644
index 5492997f336e..000000000000
--- a/dev-libs/nettle/files/nettle-3.3-ecc-add-eh.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From dcda81d796de2f4a16fd7e9e7a5d07baa288f147 Mon Sep 17 00:00:00 2001
-From: Niels Möller <nisse@lysator.liu.se>
-Date: Tue, 18 Jul 2017 20:52:30 +0200
-Subject: [PATCH] Fix for in-place ecc_add_eh.
-
-* ecc-add-eh.c (ecc_add_eh): Fix in-place operation by reordering
-two multiplies. Previously, in-place operation resulted in an
-invalid call to mpn_mul with overlapping operands. Reported by
-Sergei Trofimovich.
----
- ChangeLog | 7 +++++++
- ecc-add-eh.c | 4 ++--
- 2 files changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/ecc-add-eh.c b/ecc-add-eh.c
-index a16be4c..c07ff49 100644
---- a/ecc-add-eh.c
-+++ b/ecc-add-eh.c
-@@ -98,8 +98,8 @@ ecc_add_eh (const struct ecc_curve *ecc,
- ecc_modp_mul (ecc, x3, B, z1);
-
- /* y3 */
-- ecc_modp_mul (ecc, B, F, C); /* ! */
-- ecc_modp_mul (ecc, y3, B, z1);
-+ ecc_modp_mul (ecc, B, F, z1); /* ! */
-+ ecc_modp_mul (ecc, y3, B, C); /* Clobbers z1 in case r == p. */
-
- /* z3 */
- ecc_modp_mul (ecc, B, F, G);
---
-libgit2 0.25.0
-
diff --git a/dev-libs/nettle/nettle-3.3-r2.ebuild b/dev-libs/nettle/nettle-3.3-r2.ebuild
deleted file mode 100644
index 678fb2445ce8..000000000000
--- a/dev-libs/nettle/nettle-3.3-r2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools multilib-build multilib-minimal multilib toolchain-funcs
-
-DESCRIPTION="Low-level cryptographic library"
-HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-3 LGPL-2.1 )"
-SLOT="0/6.1" # subslot = libnettle soname version, .1 as broke ABI bug#601512
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +gmp neon static-libs test cpu_flags_x86_aes"
-
-DEPEND="gmp? ( >=dev-libs/gmp-5.0:0=[${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/nettle/nettle-stdint.h
- /usr/include/nettle/version.h
-)
-
-DOCS=()
-HTML_DOCS=()
-
-PATCHES=(
- "${FILESDIR}/${P}-ecc-add-eh.patch"
-)
-
-pkg_setup() {
- use doc && DOCS+=(
- nettle.pdf
- )
- use doc && HTML_DOCS+=(
- nettle.html
- )
-}
-
-src_prepare() {
- default
-
- sed -e '/CFLAGS=/s: -ggdb3::' \
- -e 's/solaris\*)/sunldsolaris*)/' \
- -i configure.ac || die
-
- # conditionally build tests and examples required by tests
- use test || sed -i '/SUBDIRS/s/testsuite examples//' Makefile.in || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- # --disable-openssl bug #427526
- ECONF_SOURCE="${S}" econf \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-openssl \
- --disable-fat \
- $(use_enable gmp public-key) \
- $(use_enable static-libs static) \
- $(tc-is-static-only && echo --disable-shared) \
- $(use_enable doc documentation) \
- $(use_enable neon arm-neon) \
- $(use_enable cpu_flags_x86_aes x86-aesni)
-}