summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/abcl/abcl-1.5.0.ebuild')
-rw-r--r--dev-lisp/abcl/abcl-1.5.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-lisp/abcl/abcl-1.5.0.ebuild b/dev-lisp/abcl/abcl-1.5.0.ebuild
deleted file mode 100644
index 6cb5cefcfec9..000000000000
--- a/dev-lisp/abcl/abcl-1.5.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_P=${PN}-src-${PV}
-
-DESCRIPTION="Armed Bear Common Lisp is a Common Lisp implementation for the JVM."
-HOMEPAGE="http://common-lisp.net/project/armedbear/"
-SRC_URI="http://abcl.org/releases/${PV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.5"
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}"/${MY_P}
-
-src_compile() {
- eant abcl.compile || die "Can't compile ABCL"
- eant abcl.jar || die "Can't make ABCL jar archive"
-}
-
-src_install() {
- java-pkg_dojar dist/abcl.jar
- java-pkg_dolauncher ${PN} --java_args "-server -Xrs" --main org.armedbear.lisp.Main
- dodoc README || die "Can't install README"
-}