summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/hyperspec')
-rw-r--r--dev-lisp/hyperspec/Manifest1
-rw-r--r--dev-lisp/hyperspec/hyperspec-7.0-r1.ebuild36
-rw-r--r--dev-lisp/hyperspec/hyperspec-7.0.ebuild40
-rw-r--r--dev-lisp/hyperspec/metadata.xml5
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-lisp/hyperspec/Manifest b/dev-lisp/hyperspec/Manifest
new file mode 100644
index 000000000000..3d91f6795d81
--- /dev/null
+++ b/dev-lisp/hyperspec/Manifest
@@ -0,0 +1 @@
+DIST HyperSpec-7-0.tar.gz 2032830 RMD160 f6908e28635a45e8736293be11dbc1e478631674 SHA1 7c89db8a930b7bd1fd204a458a5dd05d7d46ab81 SHA256 1ac1666a9dc697dbd8881262cad4371bcd2e9843108b643e2ea93472ba85d7c3
diff --git a/dev-lisp/hyperspec/hyperspec-7.0-r1.ebuild b/dev-lisp/hyperspec/hyperspec-7.0-r1.ebuild
new file mode 100644
index 000000000000..b87f5c8dcebf
--- /dev/null
+++ b/dev-lisp/hyperspec/hyperspec-7.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PV=${PV/./-}
+MY_P=HyperSpec-${MY_PV}
+
+DESCRIPTION="Common Lisp ANSI-standard Hyperspec"
+HOMEPAGE="http://www.lispworks.com/reference/HyperSpec/"
+SRC_URI="ftp://ftp.lispworks.com/pub/software_tools/reference/${MY_P}.tar.gz"
+LICENSE="HyperSpec"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+DEPEND=""
+
+RESTRICT="mirror fetch"
+
+S=${WORKDIR}/
+
+pkg_nofetch() {
+ while read line; do elog "${line}"; done <<EOF
+
+The HyperSpec cannot be redistributed. Download the ${MY_P}.tar.gz
+file from http://www.lispworks.com/documentation/HyperSpec/ and move it to
+/usr/portage/distfiles before rerunning emerge. The legal conditions are
+described at http://www.lispworks.com/reference/HyperSpec/Front/Help.htm#Legal
+
+EOF
+}
+
+src_install() {
+ dodir /usr/share/doc/${P}
+ cp -r HyperSpec* ${D}/usr/share/doc/${P}
+ dosym /usr/share/doc/${P} /usr/share/doc/hyperspec
+}
diff --git a/dev-lisp/hyperspec/hyperspec-7.0.ebuild b/dev-lisp/hyperspec/hyperspec-7.0.ebuild
new file mode 100644
index 000000000000..1102360d763e
--- /dev/null
+++ b/dev-lisp/hyperspec/hyperspec-7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PV=${PV/./-}
+
+DESCRIPTION="Common Lisp ANSI-standard Hyperspec"
+HOMEPAGE="http://www.lispworks.com/reference/HyperSpec/"
+SRC_URI=""
+LICENSE="HyperSpec"
+SLOT="0"
+KEYWORDS="x86 amd64 sparc ppc"
+IUSE=""
+DEPEND=""
+
+# URL: ftp://ftp.lispworks.com/pub/software_tools/reference/HyperSpec-7-0.tar.gz
+
+S=${WORKDIR}/
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/HyperSpec-${MY_PV}.tar.gz ]; then
+ while read line; do elog "${line}"; done <<EOF
+
+The HyperSpec cannot be redistributed. Download the HyperSpec-${PV//./-}.tar.gz
+file from http://www.lispworks.com/documentation/HyperSpec/ and move it to
+/usr/portage/distfiles before rerunning emerge. The legal conditions are
+described at http://www.lispworks.com/reference/HyperSpec/Front/Help.htm#Legal
+
+EOF
+ die
+ else
+ unpack HyperSpec-${MY_PV}.tar.gz
+ fi
+}
+
+src_install() {
+ dodir /usr/share/doc/${P}
+ cp -r HyperSpec* ${D}/usr/share/doc/${P}
+ dosym /usr/share/doc/${P} /usr/share/doc/hyperspec
+}
diff --git a/dev-lisp/hyperspec/metadata.xml b/dev-lisp/hyperspec/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/hyperspec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>