summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luaevent/luaevent-0.4.6.ebuild')
-rw-r--r--dev-lua/luaevent/luaevent-0.4.6.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lua/luaevent/luaevent-0.4.6.ebuild b/dev-lua/luaevent/luaevent-0.4.6.ebuild
deleted file mode 100644
index 84700e9d48e4..000000000000
--- a/dev-lua/luaevent/luaevent-0.4.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="libevent bindings for Lua"
-HOMEPAGE="http://luaforge.net/projects/luaevent"
-SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RDEPEND="dev-lang/lua:0
- dev-libs/libevent:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- sed -i "s:^CFLAGS =:CFLAGS +=:" "${S}/Makefile" \
- || die "sed failed"
- sed -i "s:^LDFLAGS =:LDFLAGS +=:" "${S}/Makefile" \
- || die "sed failed"
- sed -i "/^LDFLAGS/a CC = $(tc-getCC)" "${S}/Makefile" \
- || die "sed failed"
- sed -i "s:^LUA_INC_DIR ?=.*:LUA_INC_DIR ?= $(pkg-config --variable INSTALL_INC lua):" "${S}/Makefile" \
- || die "sed failed"
- sed -i "s:^INSTALL_DIR_LUA ?=.*:INSTALL_DIR_LUA ?= $(pkg-config --variable INSTALL_LMOD lua):" "${S}/Makefile" \
- || die "sed failed"
- sed -i "s:^INSTALL_DIR_BIN ?=.*:INSTALL_DIR_BIN ?= $(pkg-config --variable INSTALL_CMOD lua):" "${S}/Makefile" \
- || die "sed failed"
- eapply_user
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-}