summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luarocks/luarocks-3.3.1.ebuild')
-rw-r--r--dev-lua/luarocks/luarocks-3.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lua/luarocks/luarocks-3.3.1.ebuild b/dev-lua/luarocks/luarocks-3.3.1.ebuild
new file mode 100644
index 000000000000..9cade0befc8a
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua:=
+ dev-libs/openssl:=
+ net-misc/curl"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix="${EPRIFIX}/usr" \
+ --with-lua-lib="${EPRIFIX}/usr/$(get_libdir)" \
+ --rocks-tree="${EPRIFIX}/usr/$(get_libdir)/lua/luarocks" \
+ || die "configure failed"
+}
+
+src_install() {
+ default
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die "sed failed"
+}