summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luassert/luassert-1.7.9.ebuild')
-rw-r--r--dev-lua/luassert/luassert-1.7.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lua/luassert/luassert-1.7.9.ebuild b/dev-lua/luassert/luassert-1.7.9.ebuild
new file mode 100644
index 000000000000..8a0940b54c24
--- /dev/null
+++ b/dev-lua/luassert/luassert-1.7.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua Assertions Extension"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/luassert/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-lua/say-1.2_p1"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
+doins -r src/*
+dodoc *.md
+}