summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/mediator_lua')
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild
deleted file mode 100644
index 69ece31e97a9..000000000000
--- a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r100.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} luajit )
-MY_PV="${PV/_p/-}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Mediator pattern implementation for pub-sub management "
-HOMEPAGE="http://olivinelabs.com/mediator_lua/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- >=dev-lua/busted-2.0.0-r100
- ${RDEPEND}
- )
-"
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)
- doins src/mediator.lua
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}