summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/async_extra')
-rw-r--r--dev-ml/async_extra/Manifest3
-rw-r--r--dev-ml/async_extra/async_extra-112.17.00.ebuild37
-rw-r--r--dev-ml/async_extra/async_extra-112.24.00.ebuild37
-rw-r--r--dev-ml/async_extra/async_extra-112.35.00.ebuild38
-rw-r--r--dev-ml/async_extra/metadata.xml5
5 files changed, 120 insertions, 0 deletions
diff --git a/dev-ml/async_extra/Manifest b/dev-ml/async_extra/Manifest
new file mode 100644
index 000000000000..f74cb11578c2
--- /dev/null
+++ b/dev-ml/async_extra/Manifest
@@ -0,0 +1,3 @@
+DIST async_extra-112.17.00.tar.gz 157687 SHA256 97782934e98808e1e667c00f90ef08b6a55b6a462c86a2afefb0ee12189cecd8 SHA512 338a3ed19cd17c16739737c8854a40195912dfdccfb370aa39ec6d2c516f33a69ddb01115fe3616261f17578796a404330b3c6f99f8493b7969c5e3b1c67d397 WHIRLPOOL 8617d6dbb34c75051e5ab67c72f5a8545084ea3c7e3326e59ade777a644b8a37b0a9f20c5f2908a37e2047ac197c88b009c6a25ea4261a065df491263ef6a99a
+DIST async_extra-112.24.tar.gz 161501 SHA256 51f6f67a9ad56fe5dcf09faeeca6ec2fea53a7a975a72bc80504b90841212e28 SHA512 9ac13275a3b004ce87f2858634e06e2e8ff0a6a014023af25571fbf3de8c18a5396c42df0c3df647be094d348f2a6fa911004d9e6a877827ce87c2f8fa16305d WHIRLPOOL ce5e7581d4ed320e35465b11da5978bdf335ab04bb72aac5e3416e66db01cf2f8cfdad79f2b4906de681cb270523c5c6625718bed2a836d38f2f4e84487273b2
+DIST async_extra-112.35.00.tar.gz 145974 SHA256 2bb3683c6a8f9100f5fa09edcbd885a9253973f33a7ad6344fed10cd2aa5733c SHA512 25fc649d4272631068f4d19c472f13ed81645b321d1b80b498bdc7acd1070af8b0c4ddad08fba09b836b093d985cdd52e39ee672b949ff7085c66ee7599e6144 WHIRLPOOL f2cfa6ef0dfe64ee6f8fd5091b85cbc9918c46db54c8031575166c6c7d40e5e66f9cb3236db676a8426b2dc605a9e23f5495f681641105d783f7653fa9c22d8c
diff --git a/dev-ml/async_extra/async_extra-112.17.00.ebuild b/dev-ml/async_extra/async_extra-112.17.00.ebuild
new file mode 100644
index 000000000000..facc5d31eaf7
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-112.17.00.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-${PV}:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ dev-ml/custom_printf:=
+ dev-ml/herelib:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_extra/async_extra-112.24.00.ebuild b/dev-ml/async_extra/async_extra-112.24.00.ebuild
new file mode 100644
index 000000000000..5fc3a6cf4cd7
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-112.24.00.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-${PV}:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ dev-ml/custom_printf:=
+ dev-ml/herelib:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_extra/async_extra-112.35.00.ebuild b/dev-ml/async_extra/async_extra-112.35.00.ebuild
new file mode 100644
index 000000000000..2df0a37e4c20
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-112.35.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-${PV}:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ dev-ml/custom_printf:=
+ dev-ml/herelib:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ dev-ml/async_rpc_kernel:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_extra/metadata.xml b/dev-ml/async_extra/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/async_extra/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>