summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camomile/camomile-1.0.2.ebuild')
-rw-r--r--dev-ml/camomile/camomile-1.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/camomile/camomile-1.0.2.ebuild b/dev-ml/camomile/camomile-1.0.2.ebuild
new file mode 100644
index 000000000000..56a31353629c
--- /dev/null
+++ b/dev-ml/camomile/camomile-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml"
+HOMEPAGE="https://github.com/yoriyuki/Camomile/wiki"
+SRC_URI="https://github.com/yoriyuki/Camomile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+
+# Unbound module errors
+RESTRICT="test"
+
+src_compile() {
+ # Amend standard dune_src_compile with -p camomile
+ # Needed to workaround: https://github.com/yoriyuki/Camomile/issues/83
+ # (https://dune.readthedocs.io/en/stable/faq.html#how-to-make-warnings-non-fatal)
+ dune build -p camomile @install || die
+}