summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/charinfo_width/charinfo_width-1.1.0.ebuild')
-rw-r--r--dev-ml/charinfo_width/charinfo_width-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/charinfo_width/charinfo_width-1.1.0.ebuild b/dev-ml/charinfo_width/charinfo_width-1.1.0.ebuild
new file mode 100644
index 000000000000..93fb360c531e
--- /dev/null
+++ b/dev-ml/charinfo_width/charinfo_width-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="charInfo_width"
+DUNE_PKG_NAME="${MY_PN}"
+
+inherit dune
+
+DESCRIPTION="Determine column width for a character"
+HOMEPAGE="https://github.com/kandu/charInfo_width"
+SRC_URI="https://github.com/kandu/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/ppx_expect:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}"