summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/eliom/eliom-4.2.ebuild')
-rw-r--r--dev-ml/eliom/eliom-4.2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-ml/eliom/eliom-4.2.ebuild b/dev-ml/eliom/eliom-4.2.ebuild
deleted file mode 100644
index 4f7efd737f58..000000000000
--- a/dev-ml/eliom/eliom-4.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib findlib
-
-DESCRIPTION="A web framework to program client/server applications"
-HOMEPAGE="http://ocsigen.org/eliom/"
-SRC_URI="https://github.com/ocsigen/eliom/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="doc +ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-4.00:=[ocamlopt?]
- >=dev-ml/js_of_ocaml-2.5-r1:=
- >=www-servers/ocsigenserver-2.5:=
- >=dev-ml/tyxml-3.6:=
- >=dev-ml/deriving-0.6:=
- dev-ml/reactiveData:=
- dev-ml/ocaml-ipaddr:=
- dev-ml/react:=
- dev-ml/ocaml-ssl:=
- >=dev-ml/lwt-2.5.0:=
- dev-ml/calendar:="
-DEPEND="${RDEPEND}
- dev-ml/opam"
-
-src_prepare() {
- epatch "${FILESDIR}/tyxml36.patch"
-}
-
-src_compile() {
- if use ocamlopt ; then
- emake all
- else
- emake byte
- fi
- use doc && emake doc
- emake man
-}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- --mandir="${ED}/usr/share/man" \
- || die
- dodoc CHANGES README
- if use doc ; then
- docinto client/html
- dodoc -r _build/src/lib/client/api.docdir/*
- docinto server/html
- dodoc -r _build/src/lib/server/api.docdir/*
- fi
-}