summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fieldslib/fieldslib-0.16.0.ebuild')
-rw-r--r--dev-ml/fieldslib/fieldslib-0.16.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/fieldslib/fieldslib-0.16.0.ebuild b/dev-ml/fieldslib/fieldslib-0.16.0.ebuild
new file mode 100644
index 000000000000..fe32ece0414e
--- /dev/null
+++ b/dev-ml/fieldslib/fieldslib-0.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Folding over record fields"
+HOMEPAGE="https://github.com/janestreet/fieldslib"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ dev-ml/findlib:=
+"
+DEPEND="${RDEPEND}"