summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/iTeML/iTeML-2.3.ebuild')
-rw-r--r--dev-ml/iTeML/iTeML-2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/iTeML/iTeML-2.3.ebuild b/dev-ml/iTeML/iTeML-2.3.ebuild
new file mode 100644
index 000000000000..a13efbe16629
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ !dev-ml/qckeck
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}