summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
index f10bf23e527d..575154be6047 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm llvm.org python-any-r1
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -82,7 +82,7 @@ src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
# also: custom rules for OCaml do not work for CPPFLAGS
use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
local llvm_libdir=$(llvm-config --libdir)
# an ugly hack; TODO: figure out a way to pass -L to ocaml...
@@ -98,13 +98,13 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile ocaml_all
+ cmake_build ocaml_all
}
src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-llvm-bindings-ocaml
+ cmake_build check-llvm-bindings-ocaml
}
src_install() {