summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/luv/luv-0.5.10-r3.ebuild')
-rw-r--r--dev-ml/luv/luv-0.5.10-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/luv/luv-0.5.10-r3.ebuild b/dev-ml/luv/luv-0.5.10-r3.ebuild
new file mode 100644
index 000000000000..bab7576ca5ce
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.10-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+HOMEPAGE="https://github.com/aantron/luv"
+SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <=dev-lang/ocaml-4.13:=[ocamlopt?]
+ dev-libs/libuv:=
+ dev-ml/ocaml-ctypes:=[ocamlopt?]
+ dev-ml/result:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gnuconfig
+ test? ( dev-ml/alcotest[ocamlopt?] )"
+
+src_prepare() {
+ default
+
+ cp "${BROOT}"/usr/share/gnuconfig/config.{guess,sub} src/c/vendor/configure/ || die
+}