summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/markup/markup-1.0.3.ebuild')
-rw-r--r--dev-ml/markup/markup-1.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-1.0.3.ebuild b/dev-ml/markup/markup-1.0.3.ebuild
new file mode 100644
index 000000000000..88b603d4d100
--- /dev/null
+++ b/dev-ml/markup/markup-1.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.ml-${PV}
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/lwt:=
+ dev-ml/uchar:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"