summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mccs/mccs-1.1.13.ebuild')
-rw-r--r--dev-ml/mccs/mccs-1.1.13.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/mccs/mccs-1.1.13.ebuild b/dev-ml/mccs/mccs-1.1.13.ebuild
new file mode 100644
index 000000000000..9c0417e9c5bc
--- /dev/null
+++ b/dev-ml/mccs/mccs-1.1.13.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV=$(ver_rs 2 '+')
+
+DESCRIPTION="Multi Criteria CUDF Solver"
+HOMEPAGE="http://www.i3s.unice.fr/~cpjm/misc/ https://github.com/AltGr/ocaml-mccs/issues"
+SRC_URI="https://github.com/AltGr/ocaml-mccs/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/ocaml-${PN}-$(ver_rs 2 '-')
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cudf:=
+ sci-mathematics/glpk:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/extlib:=
+ )
+"