summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/merlin-extend/merlin-extend-0.6.1.ebuild')
-rw-r--r--dev-ml/merlin-extend/merlin-extend-0.6.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/merlin-extend/merlin-extend-0.6.1.ebuild b/dev-ml/merlin-extend/merlin-extend-0.6.1.ebuild
new file mode 100644
index 000000000000..2e233f143af0
--- /dev/null
+++ b/dev-ml/merlin-extend/merlin-extend-0.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="SDK to extend Merlin"
+HOMEPAGE="https://github.com/let-def/merlin-extend/"
+SRC_URI="https://github.com/let-def/merlin-extend/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="
+ ${RDEPEND}
+ dev-ml/cppo
+"