summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mirage-profile/mirage-profile-0.5.ebuild')
-rw-r--r--dev-ml/mirage-profile/mirage-profile-0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/mirage-profile/mirage-profile-0.5.ebuild b/dev-ml/mirage-profile/mirage-profile-0.5.ebuild
new file mode 100644
index 000000000000..a4fe4a8a6e69
--- /dev/null
+++ b/dev-ml/mirage-profile/mirage-profile-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Collect profiling information"
+HOMEPAGE="https://github.com/mirage/mirage-profile https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/io-page:=
+ dev-ml/lwt:=
+ dev-ml/ocaml-cstruct:=[camlp4(-)]
+ dev-ml/ocplib-endian:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.md )