summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-data-notation')
-rw-r--r--dev-ml/ocaml-data-notation/Manifest2
-rw-r--r--dev-ml/ocaml-data-notation/metadata.xml10
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild28
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild25
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/ocaml-data-notation/Manifest b/dev-ml/ocaml-data-notation/Manifest
new file mode 100644
index 000000000000..507b8f4f7f9b
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-data-notation-0.0.10.tar.gz 63163 SHA256 e61d1dc014770b552f005ece61a242ffc6a72471050335ecc3e6ee93710d9fbd SHA512 339ac99f835e2718cb98e7491e482d23028b80834fe43c1cb83aab5ec31d5d1732783dd785b216ab93f37ea2f39fbe247f48886c6e8b02193a21572aca1ba45e WHIRLPOOL 30cba39bc7fc53bcc0e6cb8ced6beffcb24d83dc7cef67df99b6d26d32b141c48601e1a4f1cdd02ed622396d0eb48e06d9a6b9712d7410f41e28d5e8ddfe64ba
+DIST ocaml-data-notation-0.0.11.tar.gz 63968 SHA256 928ef4c76338e810808c4faa92300bc30b120c10e9ed0609b5825d177dfb4825 SHA512 010c6105b0745c4dbf426186915078cd71d02d56e19ca01089a37f803c9d81c02a22e64184b9b4a42d44450834527a050ff20430f8c2d8a972610717f4c653d7 WHIRLPOOL 2bd6bc585db4e249b263712c0c35e7885488580c8799a09222db30bbb0fc3992b99a437fb335243169ea97ea395ee201a78027e20ee511715f69b8196175e4d6
diff --git a/dev-ml/ocaml-data-notation/metadata.xml b/dev-ml/ocaml-data-notation/metadata.xml
new file mode 100644
index 000000000000..769e0b77304f
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>v.ivanov@ymail.com</email>
+ <name>Vladimir Ivanov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild
new file mode 100644
index 000000000000..13183f5b5077
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="http://forge.ocamlcore.org/projects/odn"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1029/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/type-conv-108.07.01:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] dev-ml/ocaml-fileutils[ocamlopt?] )"
+
+DOCS=( "README.txt" "AUTHORS.txt" "CHANGES.txt" )
+
+src_prepare() {
+ sed -i -e 's/type-conv/type_conv/' tests/test.ml || die
+}
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
new file mode 100644
index 000000000000..168330a2e762
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="http://forge.ocamlcore.org/projects/odn"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1310/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/type-conv-108.07.01:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-2.0.0[ocamlopt?] dev-ml/ocaml-fileutils[ocamlopt?] )"
+
+DOCS=( "README.txt" "AUTHORS.txt" "CHANGES.txt" )