summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch')
-rw-r--r--dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch b/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch
new file mode 100644
index 000000000000..cbed5cbf2da0
--- /dev/null
+++ b/dev-ml/ocaml-expat/files/ocaml-expat-0.9.1-test.patch
@@ -0,0 +1,35 @@
+Index: ocaml-expat-0.9.1/Makefile
+===================================================================
+--- ocaml-expat-0.9.1.orig/Makefile
++++ ocaml-expat-0.9.1/Makefile
+@@ -67,7 +67,7 @@ doc: FORCE
+ testall: test testopt
+ .PHONY: test
+ test: unittest
+- ./unittest
++ LD_LIBRARY_PATH=. ./unittest
+ .PHONY: testopt
+ testopt: unittest.opt
+ ./unittest.opt
+Index: ocaml-expat-0.9.1/unittest.ml
+===================================================================
+--- ocaml-expat-0.9.1.orig/unittest.ml
++++ ocaml-expat-0.9.1/unittest.ml
+@@ -497,7 +497,7 @@ let suite = "expat" >:::
+ something obviously wrong. *)
+ loop do_stuff 10
+ );
+-
++(*
+ "another garbage collection test" >::
+ (fun _ ->
+ let parse _ =
+@@ -530,7 +530,7 @@ let suite = "expat" >:::
+ close_in xml_spec
+ in
+ loop parse 10
+- );
++ );*)
+ ];;
+
+ let _ =