summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha')
-rw-r--r--dev-ml/ocaml-sha/Manifest2
-rw-r--r--dev-ml/ocaml-sha/metadata.xml8
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild28
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild29
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
new file mode 100644
index 000000000000..78939a296722
--- /dev/null
+++ b/dev-ml/ocaml-sha/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-sha-1.8.tar.gz 11911 SHA256 473c67cc95629ed7bf788bdc08a6d829dc953c223628bc030ecaa28c0cf3245d SHA512 53a0c86d239a4b98b4ce5236c20f97273f9bb4cde539ed248712cdb35fa49df998db2b5a57343e555907848885a46846e932934d15477ad65c321d9e2a5c1e60 WHIRLPOOL a8309f445ac95ac9c497afadd5285420310e09687bfde1de60c2bfb1d838611cca15c6ae80d1e4a8e90379d304d510875e8249931ac2a39950df1037a38a9a12
+DIST ocaml-sha-v1.9.tar.gz 12872 SHA256 caa1dd9071c2c56ca180061bb8e1824ac3b5e83de8ec4ed197275006c2a088d0 SHA512 e49f725f0544a423c57199b2534519a005916f24a17bf7761e744ec963c5712b8b0b82b052d87c55fdfd3143f194f44283c7332ab08f480328c0c21642ae5778 WHIRLPOOL ab616f746e7a30ebf17758b5320ed34ac0126fe4fe1674c8d58021ba5469b9fddd9f20f55b4755c9774bec3a3e00399f6b08f1861b33be5724eae3916d9fd0d6
diff --git a/dev-ml/ocaml-sha/metadata.xml b/dev-ml/ocaml-sha/metadata.xml
new file mode 100644
index 000000000000..3776475e41b1
--- /dev/null
+++ b/dev-ml/ocaml-sha/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">vincenthz/ocaml-sha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
new file mode 100644
index 000000000000..86eb3b52908f
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://nodeload.github.com/vincenthz/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
new file mode 100644
index 000000000000..ad4737c153cb
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="http://github.com/vincenthz/ocaml-sha"
+SRC_URI="http://github.com/vincenthz/ocaml-sha/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}