summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-text/ocaml-text-0.6.ebuild')
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/ocaml-text-0.6.ebuild b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
new file mode 100644
index 000000000000..d5689475d3e2
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/937/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+DEPEND="virtual/libiconv
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "CHANGES" "CHANGES.darcs" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}