summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
index 8976098b07bc..135e3afb853c 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit findlib
+inherit findlib toolchain-funcs
MY_P=${P/_beta/test}
DESCRIPTION="Modules for OCaml application-level Internet protocols"
@@ -61,6 +61,7 @@ src_configure() {
$(ocamlnet_use_enable tk tcl) \
$(ocamlnet_use_enable zip zip) \
$(ocamlnet_use_with httpd nethttpd) \
+ -cpp $(tc-getPROG CPP cpp) \
|| die "Error: econf failed!"
}