summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild')
-rw-r--r--dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
new file mode 100644
index 000000000000..70381f8c32d2
--- /dev/null
+++ b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parser for ocaml documentation comments"
+HOMEPAGE="https://github.com/ocaml-doc/odoc-parser"
+SRC_URI="https://github.com/ocaml-doc/odoc-parser/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/result:=
+ dev-ml/camlp-streams:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/ppx_expect
+)"