summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam/opam-1.2.2-r1.ebuild')
-rw-r--r--dev-ml/opam/opam-1.2.2-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-ml/opam/opam-1.2.2-r1.ebuild b/dev-ml/opam/opam-1.2.2-r1.ebuild
deleted file mode 100644
index 2b94b7e93d95..000000000000
--- a/dev-ml/opam/opam-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="A source-based package manager for OCaml"
-HOMEPAGE="http://opam.ocaml.org/"
-LICENSE="LGPL-3-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ocaml/opam.git"
-fi
-
-DEPEND="dev-lang/ocaml:=
- || ( net-misc/wget net-misc/curl )
- dev-ml/extlib:=
- dev-ml/ocaml-re:=
- dev-ml/ocamlgraph:=
- dev-ml/cmdliner:=
- dev-ml/cudf:=
- >=dev-ml/dose3-4:=
- dev-ml/uutf:=
- dev-ml/jsonm:=
-"
-RDEPEND="${DEPEND}
- dev-ml/findlib
-"
-
-src_prepare() {
- epatch \
- "${FILESDIR}/0001-Port-to-Dose3-4.0.1.patch" \
- "${FILESDIR}/no-insecure.patch"
-}
-
-src_compile() {
- emake -j1
- cd doc
- emake man
-}
-
-src_test() {
- EMAIL=foo@bar.com emake -j1 tests
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
-}