summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild
new file mode 100644
index 000000000000..15f80dd2bd25
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pcre-ocaml"
+SRC_URI="http://bitbucket.org/mmottl/pcre-ocaml/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}