summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.6.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.6.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.6.ebuild
new file mode 100644
index 000000000000..ad1d8e23fbac
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="http://bitbucket.org/mmottl/postgresql-ocaml/downloads/${P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/mmottl/postgresql-ocaml"
+IUSE="examples"
+
+DEPEND="dev-db/postgresql[server]"
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}