summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_bench/ppx_bench-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_bench/ppx_bench-113.24.00.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ml/ppx_bench/ppx_bench-113.24.00.ebuild b/dev-ml/ppx_bench/ppx_bench-113.24.00.ebuild
deleted file mode 100644
index 52d678d559ff..000000000000
--- a/dev-ml/ppx_bench/ppx_bench-113.24.00.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit oasis
-
-MY_P=${PN/-/_}-${PV}
-DESCRIPTION="Syntax extension for writing in-line benchmarks in ocaml code"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-ml/ppx_tools:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_core:="
-
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}