summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_bin_prot/ppx_bin_prot-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_bin_prot/ppx_bin_prot-0.15.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_bin_prot/ppx_bin_prot-0.15.0-r1.ebuild b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..105e3fde7628
--- /dev/null
+++ b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.15.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of bin_prot readers and writers from types"
+HOMEPAGE="https://github.com/janestreet/ppx_bin_prot"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/bin_prot:${SLOT}
+ dev-ml/ppx_here:${SLOT}
+ >=dev-ml/ppxlib-0.23.0:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"